Flash CS5 Problem

Posted by bleasc 
Flash CS5 Problem
May 06, 2010 01:15PM
Hey,
i just installed Flash CS5, and i have a huge problem... after i make any movie with flasheff effects, and save it, it works fine. After i close Flash and open it again, my fla. source doesnt work anymore as it was suppose to, if try to modify any effect i get a error:

The following JavaScript error(s) occurred:
TypeError: inst.parameters[prop] has no properties

Any ideeas how to get it to work again ?

ps: i tried this with 3-4 movies and even reinstal flasheff, and it's still the same
Re: Flash CS5 Problem
May 07, 2010 01:59AM
I'm getting the same problem… FlashEff2 does not appear to be compatible with the Flash CS5 file format. Create a FlashEff2 instance on the stage - save as a CS4 file - reopen - it's fine. But save it as either of the CS5 formats, reopen - and all is lost.



Edited 1 time(s). Last edit at 05/07/2010 02:48AM by almacrae.
Re: Flash CS5 Problem
May 07, 2010 03:34AM
I have the same problem in free version, and my friend (who have a pro account) too.

Any idea how to fix this?
Re: Flash CS5 Problem
May 07, 2010 08:43AM
guys,

Your reports brought in our attention a minor bug. It seems Flasheff2 have some difficulties to save the applied effects when Flash CS5 shuts down. Our developers are already working to fix that problem and I assure you that this is our main concern at this moment. We will update the component as soon as this bug will be fixed. A newsletter will let you know about that. I am really sorry for any inconvenience and thank you very much for bringing that problem into our attention.
Re: Flash CS5 Problem
May 11, 2010 12:17AM
and there is a problem with text patterns. in CS5 there is a different way to embed fonts and all text paterns doesn't work. could U fix this also?
Re: Flash CS5 Problem
May 11, 2010 02:50PM
sykomor,

The FlashEff2 text patterns are working fine on CS5. Indeed the embed fonts option seems to be different than it is in Flash CS3&4 because the "autoFill" option is not appearing anymore in Flash CS5. However that thing does not affect in any way the well functionality of the text patterns. You should simple set the "embed" option on the target field and hit ok.
Re: Flash CS5 Problem
May 12, 2010 08:51AM
and the problem with the save and reload is fixed ? cus' i didnt get any newsletter :)
Re: Flash CS5 Problem
May 17, 2010 02:35PM
Hello guys,

Thank you for your patience. We have fixed and updated the component. Please re-download and reinstall the component and let us know the results. Thank you.
Re: Flash CS5 Problem
June 08, 2010 08:16AM
Hi,

Still I'm having the same problem as the guy from the first post.

I wanted to edit an animation that I made few months ago using CS4 with new flash CS5 and I am getting the same message:

The following JavaScript error(s) occurred:
TypeError: inst.parameters[prop] has no properties
Re: Flash CS5 Problem
June 08, 2010 02:23PM
AmmarM,

Please make sure you are using the last version of the component and try again to open the file made with Flash CS4 (not the file made with Flash CS4 and saved as CS5 ).
Re: Flash CS5 Problem
June 10, 2010 07:05PM
Same problem here... but i found that you must replace all components by new versions and define animation from scratch. Probably component lost my custom presets...



Edited 1 time(s). Last edit at 06/10/2010 07:05PM by miloszwinkler.
Re: Flash CS5 Problem
June 11, 2010 10:52AM
miloszwinkler,

Indeed, that is true you need to replace the old component with the new one in your project file, if you want the changes to take effect.
Re: Flash CS5 Problem
September 23, 2010 08:48PM
Wow - I just lost hours of work... re opened saved projects that are now completely trashed and I have to redo all my updates. Really wish I would have been notified about this.
Re: Flash CS5 Problem
November 24, 2010 01:40PM
I have had this same problem when moving from CS4 to CS5. Had to redo all my effects. But the same problem as descibed above, The following JavaScript error(s) occurred: is still happening in a new CS5 project. Is there a fix on this yet? It doesn't seem to cause any errors and my effects appear to be working ok.
Re: Flash CS5 Problem
November 24, 2010 02:23PM
We already fixed this problem.
If you will read the posts from above I'm sure that you will manage to make this work.
"Thank you for your patience. We have fixed and updated the component. Please re-download and reinstall the component and let us know the results. Thank you."
"Please make sure you are using the last version of the component and try again to open the file made with Flash CS4 (not the file made with Flash CS4 and saved as CS5 )."
"Indeed, that is true you need to replace the old component with the new one in your project file, if you want the changes to take effect."
Re: Flash CS5 Problem
December 07, 2010 06:46PM
I have a problem.
I installed the flasheff in free version here at home.
In the Extension Manager appears to be working. says it was installed correctly.
but when I open the flash component is not there.

Can someone help me?
Re: Flash CS5 Problem
December 08, 2010 09:11AM
In FAQ section you can find a solution to this problem.
[www.flasheff.com]
Re: Flash CS5 Problem
October 21, 2011 12:25PM
Hi,


We have a problem with our action script and seems to be using cookies of clients computers.


We have a action script as under ..........----------


function my_function38()
{
var _loc1 = my_xml.firstChild.childNodes;
totalNodes = _loc1.length;
cityname_mc.fl_name_mc.fl_name.text = my_xml.firstChild.childNodes[cnt].attributes.name;
rate_mc.rate_anim_mc.fl_rate.text = my_xml.firstChild.childNodes[cnt].attributes.rate;
fl_month.text = my_xml.firstChild.childNodes[cnt].attributes.month;
}


// End of the function
my_Date = new Date();
my_xml = new XML();
my_xml.load("DEL.xml?uniqueID=" + getTimer());
my_xml.onLoad = my_function38;


my_xml.ignoreWhite = 1;
if (!cnt)
{
var cnt = 0;
} // end if
++cnt;
if (cnt >= totalNodes)
{
cnt = 0;
gotoAndPlay(1);
}
else
{
gotoAndPlay(1);
}

----------------------------------------------------------------------------------------------------

Xml Data as under
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

<?xml version="1.0" encoding= "UTF-8" ?>
<cities>
<city name="Delhi" rate="£365" month=""file location"></city>
</cities>
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------






What is happening is we are storing many swf files and xml files for different cities on server location 1 with same code but are just changing the xml file to be picked.
I.e


DELHI.XML DELHI.SWF
BANGKOK.XML BANGKOK.SWF
SYDNEY.XML SYDNEY.SWF


All are in one folder and we are just changing the xml path in fla files and loading the new swf.

Then we are giving out swf urls to an advertising company which is in turn picking up swf files from sever location 1 and displaying the same on their website.


The problem is each time we access the swf file on there site the data doesnot display properly. It is picking up the wrong xml data. When we check the fla the path for xml is ok. What we think is it is saving swf or xml in cookies of user computer. Is there anyway to prevent it from happening.




We Are using Adobe Flash CS5.




Thanks
kam.p
Re: Flash banner Problem
October 21, 2011 12:26PM
Hi,


We have a problem with our action script and seems to be using cookies of clients computers.


We have a action script as under ..........----------


function my_function38()
{
var _loc1 = my_xml.firstChild.childNodes;
totalNodes = _loc1.length;
cityname_mc.fl_name_mc.fl_name.text = my_xml.firstChild.childNodes[cnt].attributes.name;
rate_mc.rate_anim_mc.fl_rate.text = my_xml.firstChild.childNodes[cnt].attributes.rate;
fl_month.text = my_xml.firstChild.childNodes[cnt].attributes.month;
}


// End of the function
my_Date = new Date();
my_xml = new XML();
my_xml.load("DEL.xml?uniqueID=" + getTimer());
my_xml.onLoad = my_function38;


my_xml.ignoreWhite = 1;
if (!cnt)
{
var cnt = 0;
} // end if
++cnt;
if (cnt >= totalNodes)
{
cnt = 0;
gotoAndPlay(1);
}
else
{
gotoAndPlay(1);
}

----------------------------------------------------------------------------------------------------

Xml Data as under
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

<?xml version="1.0" encoding= "UTF-8" ?>
<cities>
<city name="Delhi" rate="£365" month=""file location"></city>
</cities>
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------






What is happening is we are storing many swf files and xml files for different cities on server location 1 with same code but are just changing the xml file to be picked.
I.e


DELHI.XML DELHI.SWF
BANGKOK.XML BANGKOK.SWF
SYDNEY.XML SYDNEY.SWF


All are in one folder and we are just changing the xml path in fla files and loading the new swf.

Then we are giving out swf urls to an advertising company which is in turn picking up swf files from sever location 1 and displaying the same on their website.


The problem is each time we access the swf file on there site the data doesnot display properly. It is picking up the wrong xml data. When we check the fla the path for xml is ok. What we think is it is saving swf or xml in cookies of user computer. Is there anyway to prevent it from happening.




We Are using Adobe Flash CS5.




Thanks
kam.p
Sorry, only registered users may post in this forum.

Click here to login