Gaia framework doesnt work with FlashEff

Posted by captainjon 
Gaia framework doesnt work with FlashEff
November 03, 2010 10:50AM

I've tried using the Gaia framework with CS4 and when I add a flashEff component to some text, the text does not show.
I added instance name of the textfield to the document class, as that was an initial error.

Anyone worked this one out?

Re: Gaia framework doesnt work with FlashEff
November 03, 2010 02:27PM
We can't guarantee that the component will work properly in other applications than Adobe flash. So, if you don't manage to make the component works in flash CS4, CS5, CS3, then, you should let us know, and give us exact and detailed information about what you did, so, that we can make an idea of what you tried to do and also to find out where the problem is.
Is there a solution work with GAIA ?
October 23, 2011 02:34PM
I bought FlashEff2 yesterday then I'm learning and testing. This is great app & thank you developers but I have one problem.

I testing with CS 5.5 and GAIA 3.2.6 which they are up-to-date versions for now. I created a GAIA ( AS3 and Flash player 10) project, I didn't setup complex scaffold just one default home page and I put a simple box on homepage stage and just added a show effect "alpha - default". I test it but it stucked at first preloader %100 and Flash gave me an error that is:

Flash Error
Gaia Framework (AS3) v3.2.6
ReferenceError: Error #1056: Cannot create property simple_box_mc on pages.HomePage.
at flash.display::Sprite/constructChildren()
at flash.display::Sprite()
at flash.display::MovieClip()
at com.gaiaframework.templates::AbstractBase()
at com.gaiaframework.templates::AbstractPage()
at pages::HomePage

After that I opened all flas they created by GAIA and I drag FlashEff2 component to their libraries (I thought maybe main.fla, index.fla, nav.fla or preloader.fla needs this) and tested again but nothing changed.

I think there can't be easier project and detailed message than this. (maybe i did some english grammer mistakes :)

Can we solve this problem or never use FlashEff2 with GAIA ?

Edited 1 time(s). Last edit at 10/23/2011 02:53PM by cirkef.
Re: Gaia framework doesnt work with FlashEff
October 24, 2011 01:29PM
I'm not familiar with Gaia but you should try the solution that was given here [] and perhaps it will work.
Re: Gaia framework doesnt work with FlashEff
October 24, 2011 04:43PM
Thank you for answer but it couldn't solve the problem.

What I did ?

I create simple GAIA project again and I did simple fla with one box and one FlashEff2 show effect then I publish it. Finally I imported this swf to my GAIA project and tested; Flash didn't any error but effect didn't play, just show simple box without animation.

GAIA is great framework for deep linking, SEO friendly sites, rapid development etc. by the way. I believe if we can overcome this problem and use GAIA and FlashEff2 together winner side will FlashEff2 and World will be better place :) Can developers care for this situation?

So should I open for ticket ? I know you can't guarantee all flash components work well with FlashEff2 but GAIA is so important for Flash web site development.
Re: Gaia framework doesnt work with FlashEff
October 25, 2011 03:33AM
I'm full trying since two days for just start a project. All I need deep linked (with page title) with FlashEff2 transitions blank project. I searched and found another framework like GAIA which name is somaUI (v2.0.3). But I couldn't complete any test either.

Is there any FlashEff2 competible deeplinking framework ? I'm getting late for project deadline and If I'll have to do deeplinking, page titles etc I'll loose a lot of time so buying flasheff idea will turn to meaningless.

my somaUI methods and test results:

1. Method: I create somaUI project and pages which are MovieClip Page Mode then compile projects and open main.fla with flash and dived pages movieclips into library. I added simple box, converted movieclip and added simple effect. Saved and one time compiled. Flash gave an error
method 1 error
C:\Users\Cirkef\Desktop\metbir\source\front-end\src\com\soma\interfaces\, Line 1 1172: Definition __AS3__.vec:Vector could not be found.
and at browser just white screen.

2. Method: Firstly I created a simple box movieclip-flasheff2 effect fla and publish it. Then I create a somaUI project with one normal page mode. I added MovieClip asset in somaUI and Export-Compile. I tested in browser could just see my box instant (like 1 frame) but not any transition.

I'm thinking now two alternative way. 1 is learn and try to implement my own deep linking model. 2 is use somaUI with normal page mode and learn and try using flasheff with as3 codes. If I will success insert the as3 codes to somaUI's .as file. But 2 of them exhausting, boring and meaningless (in my perspective).

After all boring experiences what's your advice ?

PS: btw kneo I found this [] . I wrote messages for help both your links poster and this. First guy responded "i had no luck in doing this" second one didn't answer yet. If you look this [] my expectations are not absurd. I downloaded this guys package from here [] but it's so complex. I couldn't understand what it is exactly.

PS2: maybe I wrote with panic or complain mood but in Turkey local time is 06:17

PS3: Please respond quickly. "no you can't" is an answer at this position (I can't believe so
And I think somaUI is more (close) compatible than gaia.

have a nice day

Edited 1 time(s). Last edit at 10/25/2011 03:42AM by cirkef.
Re: Gaia framework doesnt work with FlashEff
October 25, 2011 12:32PM
We cannot guarantee that the component will work fine with any other software except the ones that we mentioned in the requirements section.
However a few moments ago I just tested flasheff with Gaia and everything worked fine. Basically I created a swf in which I applied a flasheff effect on an image. Then I uploaded the swf in a gaia project. Everything worked fine. This means that the problem that you are experiencing with gaia may not actually be related with flasheff component.
The code for uploading the swf is here:
var loader:Loader= new Loader()
loader.load(new URLRequest("test.swf"))

In the test.swf file I have an image and on it I applied a flasheff effect.
Re: Gaia framework doesnt work with FlashEff
October 27, 2011 05:15PM
Thank you kneo it work. But don't forget import flash.display.Loader; import; lines too. Yeah I'm newbie :)
Re: Gaia framework doesnt work with FlashEff
November 29, 2011 01:13PM
This problem is not really related to Gaia neither flasheff.
When Gaia scaffolds the pages and create the lib files, they are set to not automatically declare stage instances(because Gaia favor best practices), meaning when you publish the SWF, if you didnt explicit declare the stage instances on your page class,it'll throw an error exactly like that:
ReferenceError: Error #1056: Cannot create property my_stage_instance on pages.MyPage.
at flash.display::Sprite/constructChildren()
at flash.display::Sprite()
at flash.display::MovieClip()

To fix that problem, either declare your instance in the class as a public var like this:

public class HomePage extends AbstractPage {

public var myStageInstance:MovieClip;

public function HomePage(){

Alternatively, you can simply turn on the automatic declaring of stage instances, to do that, go to the publish settings of that .fla, go to the "flash" tab and on script: ActionScript 3.0, click on Settings... and finnaly check the box "automatically declare stage instances".
Sorry, you do not have permission to post/reply in this forum.