SOLVED: Confusion re: GoToFrame

Posted by BruceND75 
SOLVED: Confusion re: GoToFrame
May 26, 2009 07:10PM
I am confused. I noted that the latest download (5/19) supposedly fixed the missing GoToFrame command option. I downloaded and installed it, saw the inclusion of the GoToFrame, and assumed everything was fine. However, whenever I tried to use it, I got this error: "FLASHEFF2 ERROR: Unknown eventType. Available events are: rollOver, rollOut, press, release, doubleClick, showTransitionStart, showTransitionEnd, hideTransitionStart and hideTransitionEnd." I got this no matter what event was selected.

I reported this with a ticket. The ticket was closed with a statement that this was a beta problem, but was given no way of knowing when there might be a resolution.

Then, I noticed that, in this Forum, dipopeters seemed to feel that the 5/19 release solved the problem.

Is there a problem? Do I just need to correct something in how I use this feature? Am I waiting around for nothing, or something?

Edited 1 time(s). Last edit at 05/28/2009 05:33PM by BruceND75.
Re: Confusion re: GoToFrame
May 27, 2009 07:27AM
I use GoToFrame and it works fine, Can you attach a fla file that does not work?
Re: Confusion re: GoToFrame
May 27, 2009 03:51PM

Thanks. I couldn't figure out how to attach a file, so I forwarded the fla to your support email.

I appreciate you taking a look.

Re: Confusion re: GoToFrame
May 27, 2009 04:51PM
Does is make a difference if FlashEff "1" is installed along with the Private Beta? Could my problem be caused be a conflict between the two?
Re: Confusion re: GoToFrame
May 27, 2009 07:14PM
As a follow-up, I have tried uninstalling both the original FlashEff and FlashEff2 Private Beta and then installing again the Private Beta. I then opened a clean FLA, and set up a minimal scene with a button. I still get the above error.

Anticipating possible question: I'm running CS3 V9, with publish setting Flash Player 9.
Re: Confusion re: GoToFrame
May 28, 2009 08:23AM
Hi Bruce,

I've looked at your file and the reason it didn't work is because you were using the old version of your component. Don't forget to drag the latest component to the stage after you have installed the mxp.
Re: Confusion re: GoToFrame
May 28, 2009 03:52PM

Thanks for the advice, but I think there is something deeper going on. What you found may help me figure out what, but I still have the problem.

If you check earlier in this thread, since we communicated yesterday, I have tried some things to narrow down the problem.

Ultimately, after reinstalling FlashEff2 Private Beta cleanly, and creating a whole new document, only the FlashEff2 component on the system, and trying to get a button to work, still get the error.

Now, two things. First, I HAD installed the FlashEff2 alongside the existing FlashEff (before I uninstalled both, and reinstalled Beta).

Second, the problem occurs with any command on a button: Not just GoToFrame.

Third, it seems to me to be significant that the error message is "FLASHEFF2 ERROR: Unknown eventType" .

Will forward a copy of a (much smaller) test FLA I created from scratch with the new Beta install. My setup is still giving me the error.

Thanks for sticking with this.
Solved: Re: Confusion re: GoToFrame
May 28, 2009 05:33PM

Thanks for all your help. With your help, I have solved the problem.

It turns out that when looking at the mxp file, I had been looking at the date and not the time. I was going with the 11:00 am version, instead of the 5:20 version. The version numbers were not changed, and so I had inadvertently re-installed the 11:00 am version.

Works now.

Thanks again.
can I trigger flasheff using action script ?
June 24, 2009 09:30AM
Hi , I am working on a project using flasheff because it has some really great patterns and I was wondering is there a way to trigger the flash eff pattern by using action script instead using the flash eff panel ?

Thanks bye
Re: SOLVED: Confusion re: GoToFrame
June 26, 2009 08:58AM
Here is a list of all the methods you can use FlashEff from script: []
Hope it helps, if not the chat and the forums are at your disposal.

Sorry, you do not have permission to post/reply in this forum.